Why does my Constrain Found Set fail?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Why does my Constrain Found Set fail?

Gary Reimer-2
Hello experts;

There must be a simple answer to what I'm doing wrong. If I run the following script and then manually trigger Requests>>Constrain Found Set I get all orders where ppApproved is empty.

Enter Find Mode [ Pause: Off ]
Set Field [ Orders::ppApproved ; "=" ]
Exit Script [ Text Result:    ]
Constrain Found Set []

But if I run the following, I get an empty found set.

Enter Find Mode [ Pause: Off ]
Set Field [ Orders::ppApproved ; "=" ]
Constrain Found Set []
Exit Script [ Text Result:    ]

There has to be something obviously wrong with what I'm doing.

Thanks
Gary

_______________________________________________
FMPexperts mailing list
[hidden email]
http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au
Reply | Threaded
Open this post in threaded view
|

Re: Why does my Constrain Found Set fail?

Jonathan Fletcher-2
Gary, be sure your constrain is set to OMIT.

j.


> On May 8, 2017, at 12:54 PM, Gary Reimer <[hidden email]> wrote:
>
> Hello experts;
>
> There must be a simple answer to what I'm doing wrong. If I run the following script and then manually trigger Requests>>Constrain Found Set I get all orders where ppApproved is empty.
>
> Enter Find Mode [ Pause: Off ]
> Set Field [ Orders::ppApproved ; "=" ]
> Exit Script [ Text Result:    ]
> Constrain Found Set []
>
> But if I run the following, I get an empty found set.
>
> Enter Find Mode [ Pause: Off ]
> Set Field [ Orders::ppApproved ; "=" ]
> Constrain Found Set []
> Exit Script [ Text Result:    ]
>
> There has to be something obviously wrong with what I'm doing.
>
> Thanks
> Gary
>
> _______________________________________________
> FMPexperts mailing list
> [hidden email]
> http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au

--
Jonathan Fletcher
[hidden email]

Kentuckiana FileMaker Developers Group
Next Meeting: 5/23/17

_______________________________________________
FMPexperts mailing list
[hidden email]
http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au
Reply | Threaded
Open this post in threaded view
|

Re: Why does my Constrain Found Set fail?

Mark Rubenstein
In reply to this post by Gary Reimer-2
It’s not clear to me what you are trying to do.
You’re missing a Perform Find script step in the first example.

Mark

_______________________________________________
FMPexperts mailing list
[hidden email]
http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au
Reply | Threaded
Open this post in threaded view
|

Re: Why does my Constrain Found Set fail?

Jonathan Fletcher-2
In reply to this post by Jonathan Fletcher-2
Oops. Just reread it. You should use a regular Find to get ALL the records with an empty ppApproved.

The Constrain step is for when you want a subset of the current found set.

If you just want them all use a Perform Find in your script where you have the Constrain Found Set now.

j.


> On May 8, 2017, at 12:57 PM, Jonathan Fletcher <[hidden email]> wrote:
>
> Gary, be sure your constrain is set to OMIT.
>
> j.
>
>
>> On May 8, 2017, at 12:54 PM, Gary Reimer <[hidden email]> wrote:
>>
>> Hello experts;
>>
>> There must be a simple answer to what I'm doing wrong. If I run the following script and then manually trigger Requests>>Constrain Found Set I get all orders where ppApproved is empty.
>>
>> Enter Find Mode [ Pause: Off ]
>> Set Field [ Orders::ppApproved ; "=" ]
>> Exit Script [ Text Result:    ]
>> Constrain Found Set []
>>
>> But if I run the following, I get an empty found set.
>>
>> Enter Find Mode [ Pause: Off ]
>> Set Field [ Orders::ppApproved ; "=" ]
>> Constrain Found Set []
>> Exit Script [ Text Result:    ]
>>
>> There has to be something obviously wrong with what I'm doing.
>>
>> Thanks
>> Gary
>>
>> _______________________________________________
>> FMPexperts mailing list
>> [hidden email]
>> http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au
>
> --
> Jonathan Fletcher
> [hidden email]
>
> Kentuckiana FileMaker Developers Group
> Next Meeting: 5/23/17
>
> _______________________________________________
> FMPexperts mailing list
> [hidden email]
> http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au

--
Jonathan Fletcher
[hidden email]

Kentuckiana FileMaker Developers Group
Next Meeting: 5/23/17

_______________________________________________
FMPexperts mailing list
[hidden email]
http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au
Reply | Threaded
Open this post in threaded view
|

Re: Why does my Constrain Found Set fail?

Gary Reimer-2
In reply to this post by Mark Rubenstein
Please ignore my request for help. What I showed was a snippet of the script and it is actually working.

Sorry for the bother.

Thanks
Gary



Sent from my iPhone

> On May 8, 2017, at 11:59 AM, Mark Rubenstein <[hidden email]> wrote:
>
> It’s not clear to me what you are trying to do.
> You’re missing a Perform Find script step in the first example.
>
> Mark
>
> _______________________________________________
> FMPexperts mailing list
> [hidden email]
> http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au


_______________________________________________
FMPexperts mailing list
[hidden email]
http://lists.ironclad.net.au/listinfo.cgi/fmpexperts-ironclad.net.au